RFR: JDK-8032012, , String.toLowerCase/toUpperCase performance improvement
Ulf.Zibis at CoSoCo.de
Thu Feb 6 20:26:20 UTC 2014
To cover this problem, I filed a new language suggestion:
Am 06.02.2014 18:59, schrieb Ulf Zibis:
> I still more like the break-to-label approach. It looks more logical and saves one comparison.
> This might count on very very short strings, but I would rename it to something like
> find1stUpperCase: or scanForUpperCase.
> As an alternative you could write "if (first >= len)" as counterpart to the last "first < len"
> operation in the for loop, which therefore should be merged by JIT.
> (Or use "first != len" in the for loop.)
More information about the core-libs-dev