JDK 9 RFR of JDK-8035279: Clean up internal deprecations in BigInteger
brian.burkhalter at oracle.com
Tue Feb 25 00:32:35 UTC 2014
On Feb 20, 2014, at 6:39 PM, David Holmes wrote:
> Not clear what you mean by this.
This is more or less my reaction to this entire thread, so to speak. ;-) Anyway, thanks for all the comments.
Note that I am ignoring the powerCache field comments for the moment.
To distill the discussion down to just the proposed changes I posted, my reading is that there is more or less consensus on two points:
1) the instance fields in question *should* be volatile for this proposed change set
2) non-zero initial values should be avoided in case of instance leaking to non-constructing threads
Is this accurate?
On second thought it occurred to me that instead of any complicated or contentious changes, as it were, the ugliness I was trying to remove from the code could just as well be addressed by simply changing the names of the affected instance variables to indicate what their respective values really represent, e.g., "bitCount" becomes "bitCountPlusOne" and we remove the @Deprecated and @deprecated. Yeah this is still ugly ...
More information about the core-libs-dev