RFR: (8031737) rename jni_util.h macros for checking and returning on exceptions

roger riggs roger.riggs at oracle.com
Thu Jan 16 16:26:55 UTC 2014

Please review:

The native macros for checking and returning when exceptions
are thrown have been renamed to include the "JNU_" prefix
consistent with other functions in jni_util.h.

The macros have been renamed and existing uses in the jdk repository
for networking, pack200, and have been updated. A jprt run has passed 
(except for unrelated failures).


Thanks, Roger

[1] https://bugs.openjdk.java.net/browse/JDK-8031737

More information about the core-libs-dev mailing list