RFR: (8031737) rename jni_util.h macros for checking and returning on exceptions
Alan.Bateman at oracle.com
Thu Jan 16 16:41:10 UTC 2014
On 16/01/2014 16:26, roger riggs wrote:
> Please review:
> The native macros for checking and returning when exceptions
> are thrown have been renamed to include the "JNU_" prefix
> consistent with other functions in jni_util.h.
> The macros have been renamed and existing uses in the jdk repository
> for networking, pack200, and have been updated. A jprt run has passed
> (except for unrelated failures).
Did you mean to rename the CHECK_NULL and CHECK_NULL_RETURN macros? They
don't require a JNIEnv so I'm wondering if JNU_* really make sense here.
More information about the core-libs-dev