RFR: (8031737) rename jni_util.h macros for checking and returning on exceptions

roger riggs roger.riggs at oracle.com
Thu Jan 16 18:13:23 UTC 2014


The current do {...} while(0) is the established idiom in the jdk.

It does not have the potential problem of unintentionally allowing
an infinite loop if the body contains a 'continue'.


On 1/16/2014 12:56 PM, Ulf Zibis wrote:
> Am 16.01.2014 17:26, schrieb roger riggs:
>> Please review:
>> webrev:
>> http://cr.openjdk.java.net/~rriggs/webrev-jnu-check-rename-8031737/
> I more would like a "while (true)" loop, rather than a "do" loop.
> -Ulf

More information about the core-libs-dev mailing list