RFR: (8031737) rename jni_util.h macros for checking and returning on exceptions
roger.riggs at oracle.com
Thu Jan 16 21:49:41 UTC 2014
The webrev has been updated to revert the java.util.jar/pack CHECK_*
to clean up the macro definitions in jni_util.h.
I plan to give the review some more time in case there are more comments
> On Thu, Jan 16, 2014 at 8:26 AM, roger riggs <roger.riggs at oracle.com
> <mailto:roger.riggs at oracle.com>> wrote:
> Please review:
> The native macros for checking and returning when exceptions
> are thrown have been renamed to include the "JNU_" prefix
> consistent with other functions in jni_util.h.
> The macros have been renamed and existing uses in the jdk repository
> for networking, pack200, and have been updated. A jprt run has
> passed (except for unrelated failures).
> http://cr.openjdk.java.net/~rriggs/webrev-jnu-check-rename-8031737/ <http://cr.openjdk.java.net/%7Erriggs/webrev-jnu-check-rename-8031737/>
> Thanks, Roger
>  https://bugs.openjdk.java.net/browse/JDK-8031737
More information about the core-libs-dev