Different notations for static and instance methods
weijun.wang at oracle.com
Fri Jul 18 00:52:18 UTC 2014
We should define different notations for static and instance methods.
For example, List.of and List::of, although I admit it is quite confusing.
On Jul 18, 2014, at 5:56, Stuart Marks <stuart.marks at oracle.com> wrote:
> On 7/17/14 12:46 AM, Tom Hawtin wrote:
>> I note that with the basic proposal, HashSet.of and indeed NavigableSet.of still
>> work. They just do the wrong thing.
> I should have made more clear in the JEP that the proposed APIs are static methods on the List/Map/Set interfaces, not default methods. Thus they won't be inherited by any subinterfaces or implementors.
More information about the core-libs-dev