RFR 9: 8003488 Add Process.getPid

Florian Weimer fweimer at redhat.com
Wed Jul 23 13:08:37 UTC 2014

On 05/22/2014 05:34 PM, David M. Lloyd wrote:
> I guess this is a little late, and minor, but the "jstack" tool uses the
> acronym "nid" for this purpose, which I believe is mapped to the same
> concept (on Linux it is anyway).
> I think either this terminology should be unified on the jstack side, or
> else the method should be called "getNativeId" or "getNid" or something.

nid is the gettid return value (kernel task ID), which is distinct from 
getpid.  I doubt there are plans for exposing kernel tasks at the JDK 
level.  Even glibc attempts to hide task IDs.

Florian Weimer / Red Hat Product Security

More information about the core-libs-dev mailing list