RFR (XS) CR 8058643: (str) Re-examine hashCode implementation
xueming.shen at oracle.com
Wed Sep 17 16:13:28 UTC 2014
It definitely helps the "readability". String.hashCode() has intrinsics,
so I don't think
we are seeing the real performance "difference" of the implementations.
is the original one probably is faster.
On 9/17/14 8:25 AM, Aleksey Shipilev wrote:
> Thanks Martin!
> It used to be "Clean-up String.hashCode()", and Alan had improved it
> since then. :) To Alan's defense, the bug report was shallow at that
> point to understand what is being proposed. I changed the title to
> On 09/17/2014 07:19 PM, Martin Buchholz wrote:
>> Looks good, but I would use this title:
>> (str) Improve String.hashCode implementation
>> On Wed, Sep 17, 2014 at 7:28 AM, Aleksey Shipilev
>> <aleksey.shipilev at oracle.com <mailto:aleksey.shipilev at oracle.com>> wrote:
>> Can I have a review and a sponsorship for this tiny readability cleanup
>> in String.hashCode()?
More information about the core-libs-dev