RFR  Add blocking bulk read to java.io.InputStream
peter.levart at gmail.com
Thu Apr 23 20:06:32 UTC 2015
On 04/23/2015 06:21 PM, Chris Hegarty wrote:
> On 23 Apr 2015, at 16:58, Bernd Eckenfels <ecki at zusammenkunft.net> wrote:
>> I would use the already established name readFully(byte) and readFully(byte,int,int) to be consistent with DataInputStream.
> I purposefully stayed away from the name ‘readFully' as the spec for DataInputStream.readFully and the proposed InputStream.readBytes differs. The latter does not throw EOFException.
> So, currently, on the table we have:
> readNBytes ( thanks Alan )
What about readLoop ?
...since it's a loop of read()s
More information about the core-libs-dev