RFR 8080418 Add Optional.or()

Chris Hegarty chris.hegarty at oracle.com
Sat Sep 26 19:36:17 UTC 2015

> On 25 Sep 2015, at 11:58, Paul Sandoz <paul.sandoz at oracle.com> wrote:
> Hi,
> Please review this change to add a method Optional.or that allows one to better compose optionals:
>  http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8080418-optional-or/webrev/
> I also took the opportunity to clear up the JavaDoc, it was a little inconsistent and i personally found it harder to read in source code.

The new method and code cleanup look good.

Not related to your changes, but I noticed when reviewing the clean up, typo “OptionAL.empty()"

  L80 * {@code Option.empty()}. There is no guarantee that it is a singleton.


More information about the core-libs-dev mailing list