RFR 8135248: Add utility methods to check indexes and ranges
pbenedict at apache.org
Wed Sep 30 17:45:42 UTC 2015
+1 for having check methods start with 'require' .. that's a nice and
useful naming pattern.
On Wed, Sep 30, 2015 at 9:13 AM, Remi Forax <forax at univ-mlv.fr> wrote:
> ----- Mail original -----
> > De: "Paul Benedict" <pbenedict at apache.org>
> > À: "Peter Levart" <peter.levart at gmail.com>
> > Cc: "core-libs-dev" <core-libs-dev at openjdk.java.net>
> > Envoyé: Mercredi 30 Septembre 2015 16:06:18
> > Objet: Re: RFR 8135248: Add utility methods to check indexes and ranges
> > Ah, I was going to write about "values" ... glad this was mentioned. With
> > Valhalla working on value classes, it does raise the question if
> > range-checking is particular to Objects. Clearly it won't be once values
> > are introduced.
> > PS: I am still in favor of using Objects at the time being though just to
> > get something checked-in.
> I am in favor of Objects too,
> but I think the name (oh no bikeshedding again) should start with require*
> too make it clear that it goes with requireNonNull
> 'requireIndexInBounds' anyone ?
More information about the core-libs-dev