RFR 8162108 Rename weakCompareAndSetVolatile to weakCompareAndSet
paul.sandoz at oracle.com
Wed Aug 24 15:45:32 UTC 2016
> On 10 Aug 2016, at 17:03, Paul Sandoz <Paul.Sandoz at oracle.com> wrote:
> Please review:
> http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8162108-rename-weakCompareAndSetVolatile/webrev/ <http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8162108-rename-weakCompareAndSetVolatile/webrev/>
> This is a refactoring to produce a consistent naming scheme for the VarHandle Read Modify Write (RMW) methods. The unqualified methods default to volatile access.
> (And i hope this is the last modifying to the API signatures)
> This touches 166 classes that use or refer to the weak plain/volatile methods.
> The plan is to follow up deprecating (*not* for removal) the weakCompareAndSet methods on j.u.concurrent.atomic.* classes and add weakCompareAndSetPlain methods. Analysis via grepcode shows very little usages of the Atomic*.weakCompareAndSet methods.
> A further plan is to rename the Unsafe methods s/Swap/Set, add Plain qualifier etc.
More information about the core-libs-dev