RFR JDK-8141491: Unaligned memory access in Bits.c
mikael.vidstedt at oracle.com
Fri Feb 5 00:10:18 UTC 2016
On 2016-02-04 04:22, Andrew Haley wrote:
> On 02/02/2016 07:25 PM, Mikael Vidstedt wrote:
>> Please review this change which introduces a Copy::conjoint_swap and an
>> Unsafe.copySwapMemory method to call it from Java, along with the
>> necessary changes to have java.nio.Bits call it instead of the Bits.c code.
> One other little thing: why are the byte-swapping methods in class nio.Bits
> not called copySwapSomething? e.g.:
That sure would be a better name, wouldn't it? I'm not going to be
changing the Bits method names as part of this change, but it does seem
like a very reasonable follow-up enhancement.
More information about the core-libs-dev