RFR: jsr166 jdk9 integration wave 7

Doug Lea dl at cs.oswego.edu
Thu Jul 7 23:18:12 UTC 2016

On 07/07/2016 10:06 AM, Peter Levart wrote:

> Why the naming wasn't more like the following:

No matter which conventions you choose here, some people will be
unhappy or confused. The current scheme seems to make the current users
of both Unsafe and AtomicX least unhappy or confused.

> VarHandle.getPlain ~ /* new method */ AtomicInteger.getPlain

This is pretty close to original proposal. But ...

> Why was it chosen that plain VarHandle.get() method is without Plain suffix?

... a few people complained about the "Plain" (or in one previous
guise "Relaxed") suffix being unnecessary and inconsistently
applied. For example, should weak-CAS be renamed weakCompareAndSetPlain?


More information about the core-libs-dev mailing list