RFR: JDK-8186684: Fix broken links in java.base API docs

Martin Buchholz martinrb at google.com
Wed Aug 23 22:12:17 UTC 2017

On Wed, Aug 23, 2017 at 3:04 PM, Jonathan Gibbons <
jonathan.gibbons at oracle.com> wrote:

> Although it is not immediately clear in the webrev, the underlying
> characteristic of all places where I had to add an empty arg list is that
> there was a private field of the same name in scope.

I took a closer look at ArrayDeque.  I see no field named "add", but I do

     static final int add(int i, int distance, int modulus) {

which should probably be renamed anyways, (although overloading on arity
ought to be safe!  )

So add() would still have been ambiguous, since there are two methods

More information about the core-libs-dev mailing list