Review Request: JDK-8173712: Rename JAVA_OPTIONS environment variable to JDK_JAVA_OPTIONS

Henry Jen henry.jen at
Tue Feb 7 23:01:01 UTC 2017



> On Feb 7, 2017, at 1:16 PM, Mandy Chung <mandy.chung at> wrote:
> Henry, Kumar,
> Can you please review this patch:
> JAVA_OPTIONS was introduced by JDK-8170832 but it turns out that
> environment variable name conflicts with existing uses.  It might 
> not be uncommon for scripts to set JAVA_OPTIONS. To mitigate the
> compatibility concern, we decide to rename JAVA_OPTIONS to 
> JDK_JAVA_OPTIONS.  With multi-word name and `JDK_` prefix, that
> should reduce the chance of name clash.
> thanks
> Mandy

More information about the core-libs-dev mailing list