Review Request: JDK-8173712: Rename JAVA_OPTIONS environment variable to JDK_JAVA_OPTIONS

Alan Bateman Alan.Bateman at
Wed Feb 8 06:47:49 UTC 2017

On 07/02/2017 21:16, Mandy Chung wrote:

> Henry, Kumar,
> Can you please review this patch:
> JAVA_OPTIONS was introduced by JDK-8170832 but it turns out that
> environment variable name conflicts with existing uses.  It might
> not be uncommon for scripts to set JAVA_OPTIONS. To mitigate the
> compatibility concern, we decide to rename JAVA_OPTIONS to
> JDK_JAVA_OPTIONS.  With multi-word name and `JDK_` prefix, that
> should reduce the chance of name clash.
The rename looks okay. You might want to add to the @bug list so that it 
captures the bug with the rename.


More information about the core-libs-dev mailing list