Review Request: JDK-8173712: Rename JAVA_OPTIONS environment variable to JDK_JAVA_OPTIONS

Mandy Chung mandy.chung at
Fri Feb 10 21:57:18 UTC 2017

> On Feb 7, 2017, at 10:47 PM, Alan Bateman <Alan.Bateman at> wrote:
> On 07/02/2017 21:16, Mandy Chung wrote:
>> Henry, Kumar,
>> Can you please review this patch:
>> JAVA_OPTIONS was introduced by JDK-8170832 but it turns out that
>> environment variable name conflicts with existing uses.  It might
>> not be uncommon for scripts to set JAVA_OPTIONS. To mitigate the
>> compatibility concern, we decide to rename JAVA_OPTIONS to
>> JDK_JAVA_OPTIONS.  With multi-word name and `JDK_` prefix, that
>> should reduce the chance of name clash.
> The rename looks okay. You might want to add to the @bug list so that it captures the bug with the rename.

Thanks.  I have pushed the changeset. JDK-8170832 is linked with JDK-8173712. Hope it’s okay to leave it as is.  When some launcher change is made, we could piggy that one to update @bugs on these tests.


More information about the core-libs-dev mailing list