RFR: 8176508 Update JAX-WS RI integration to latest version
mandy.chung at oracle.com
Fri Jun 2 06:57:26 UTC 2017
> On Jun 1, 2017, at 10:29 PM, Roman Grigoriadi <roman.grigoriadi at oracle.com> wrote:
>> On 1 Jun 2017, at 21:25, Mandy Chung <mandy.chung at oracle.com <mailto:mandy.chung at oracle.com>> wrote:
>>> On May 31, 2017, at 5:06 AM, Roman Grigoriadi <roman.grigoriadi at oracle.com <mailto:roman.grigoriadi at oracle.com>> wrote:
>>> New webrev can be found here:
>>> http://cr.openjdk.java.net/~aefimov/jaxws-integrations/8176508/02/ <http://cr.openjdk.java.net/~aefimov/jaxws-integrations/8176508/02/> <http://cr.openjdk.java.net/~aefimov/jaxws-integrations/8176508/02/ <http://cr.openjdk.java.net/~aefimov/jaxws-integrations/8176508/02/>>
>> I’m happy to see this qualified exports removed.
>> Can you update jdk/test/jdk/modules/etc/JdkQualifiedExportTest.java to
>> remove "java.xml/com.sun.xml.internal.stream.writers” from KNOWN_EXCEPTION.
>> MrJarUtil::getNoPoolProperty is not MR specific. Are you trying to keep
>> the different default value when building for older release?
> In standalone MrJarUtil exists and is packaged twice, but there is no need / way to sync JDK8 and below version of this file.
> Here is second non-synced version of this file for 8 and below runtime:
> https://github.com/javaee/metro-jax-ws/blob/master/jaxws-ri/rt/src/main/java/com/sun/xml/ws/util/MrJarUtil.java <https://github.com/javaee/metro-jax-ws/blob/master/jaxws-ri/rt/src/main/java/com/sun/xml/ws/util/MrJarUtil.java>
>> It would be clearer if you want to define a constant for the default value that is subject to the runtime version.
>> XMLStreamReaderFactory and XMLStreamWriterFactory would get the property value with the MR-specific default.
> Than MrJarUtil would need to have only such constant for default value and metho getNoPoolProperty could be moved elsewhere.
Since this is the only method right now, would it be better to check if Runtime.Version class is present, then use “true” as the default for the “noPool” property; otherwise “false”. MrJarUtil seems a misleading name and maybe just move this method XMLStreamXXXFactory. It’s a suggestion. I won’t object if you want to keep this as is in JDK 9 and clean up in JDK 10 due to the timing.
More information about the core-libs-dev