RFR: 8188858: Caching latestUserDefinedLoader() results in ObjectInputStream.readObject()

Alan Bateman Alan.Bateman at oracle.com
Thu Oct 26 10:31:53 UTC 2017

On 24/10/2017 11:53, Kazunori Ogata wrote:
> :
> Comments for revising the text (and fixing my poor English) are welcome.
> Webrev: http://cr.openjdk.java.net/~horii/8188858/webrev.04/
I've read through webrev.03 and webrev.04 and they seem correct. Are 
there are more comments on the implementation? I'd like to get someone 
in the security area to review this before it is sponsored, the reason 
is that original patches could be abused and this is security-sensitive 

One comment, or suggestion, is to find a better name for the 
cachedLoader field, esp. as its value may be a Thread or a CachedLoader 
object. If CachedLoader were renamed to ReaderContext and cachedLoader 
changed to something like currentReader then it might be a bit clearer. 
I'm sure there are better names, the important thing is that future 
maintainers can quickly understand the code.


More information about the core-libs-dev mailing list