RFR 8187631 : Refactor FileDescriptor close implementation
Roger.Riggs at Oracle.com
Tue Sep 19 18:01:03 UTC 2017
I had a suggestion to use fdo and fd parameter names and to fix
On 9/19/2017 10:52 AM, Brian Burkhalter wrote:
> Hi Roger,
> On Sep 19, 2017, at 6:51 AM, Roger Riggs <Roger.Riggs at oracle.com
> <mailto:Roger.Riggs at oracle.com>> wrote:
>> The updated webrev is:
>> I avoided cluttering the initial webrev with misc cleanup.
> This looks good. The name “rawfd” is good. It could equally well be
> named “nativefd” but that’s being picky.
>> I renamed the parameters, corrected some old <code></code> markup and
>> the declarations so a side-by side diff of the Unix and Windows
>> FileDescriptor.java files
>> makes it easy to see the necessary differences.
> All good.
More information about the core-libs-dev