RFR 4358774: Add null InputStream and OutputStream
Roger.Riggs at Oracle.com
Thu Jan 11 19:16:44 UTC 2018
+1 looks fine
On 1/11/2018 11:59 AM, Brian Burkhalter wrote:
> While there appears now to be agreement on using naming option C below, formal Reviewer approval appears still to be lacking. It would be good if there were at least two approvals forthcoming, if appropriate.
> On Jan 4, 2018, at 3:42 PM, Brian Burkhalter <brian.burkhalter at oracle.com> wrote:
>> Re-reading the discussion  of last year regarding , it seems that there was convergence on all points raised except the names of the new methods. The alternatives are:
>> A) InputStream.nullStream() and OutputStream.nullStream() as in the most recent version, webrev.03,
>> B) InputStream.nullInput() and OutputStream.nullOutput() as shown above, and
>> C) InputStream.nullInputStream() and OutputStream.nullOutputStream().
>> Does anyone have any more comments on this point? I would be inclined to choose option C.
>>  http://mail.openjdk.java.net/pipermail/core-libs-dev/2017-December/050367.html
>>  https://bugs.openjdk.java.net/browse/JDK-4358774
More information about the core-libs-dev