[JDK-6341887] RFR: Patch V3: java.util.zip: Add ByteBuffer methods to Inflater/Deflater
xueming.shen at oracle.com
Thu Mar 29 04:38:39 UTC 2018
On 3/28/18, 6:14 AM, David Lloyd wrote:
>>> The current wording (which pre-dates your changes of course) reads more like
>>> API advice. I think it's a bit confusing too as it doesn't define what a
>>> "flush marker" is. I think we will need to re-word that sentence to make it
>> OK. I am at a loss for a better way to explain it though; any suggestions?
> I've implemented all the other changes except for this one. Latest
> version is attached, online version is here .
"flush marker" was copy/pasted from the original zlib.h api doc when I
support for different flush options. It might be better to put it is a
"flush marker" in this case is a 5-byte empty block, which will be
output if the
deflater does not have enough space to output the bytes and it is in
sync_flush mode. I think you can leave it as is for now and I will try
to see if I
can move it around or add some understandable wording, if I can.
More information about the core-libs-dev