RFR: JDK-8212780: JEP 343: Packaging Tool Implementation

Scott Palmer swpalmer at gmail.com
Thu Nov 1 15:30:51 UTC 2018

On Oct 30, 2018, at 1:10 PM, Andy Herrick <andy.herrick at oracle.com> wrote:
> On 10/30/2018 12:09 PM, Alan Bateman wrote:
>>> ...
>> Alex has suggested jdk.jpackager to avoid giving the impression that it's the "JDK packager". Also several existing tool modules have the tool name in the module name (jdk.jdeps, jdk.jlink, jdk.jshell, ...).
> This seems reasonable, jdk.packager -> jdk.jpackager
> still leaves the question of jdk.packager.services -> jdk.jpackager.services (or jdk.jpackager.runtime) or something else ?

I prefer jdk.jpackager.runtime.  I think  it makes more sense given the likely future functions that will be implemented there.  User JVM args support and single instance support don’t seem to fit the ’services’ name.  

I’m also hoping that the service daemon support will make it into the JDK 12 deliverable.  Is that out of the question at this point?



More information about the core-libs-dev mailing list