The application requires 10.13 or later.

Kustaa Nyholm kustaa.nyholm at
Thu Apr 4 06:25:37 UTC 2019


last night I released a new version of my app and one of the testers reported he
gets a dialog that says:

"You can't use this version of the application with this version of OS X.
You havew OS X 10.11.6. The application requires 10.13 or later."

Now this is a first version of this particular app that has been packaged with
jpackage so I suspect that this is the culprit, previous version used the
commercial JWrapper (not that it matters) which worked.

Have not investigated this further yet.

My question is if this is a true technical limitation or just that the Xcode
used to build the C-code that starts the JVM was built with settings that
prevent it from running in pre 10.13 versions and that check and dialog
was built inform the user.

Hmm ... something wrong with my thinking above as in that case it would be
OS that would put up this dialog and I would have thought that the OS can
address itself properly as it is now "macOS" and not "OS X".

So I guess the dialog is coming from the stub/launcher in .app/contents/MacOS.

But the question remains if this is a true technical limitation or policy decisions
and if so is there a work around?

Could I compile the launcher myself ?

If I gave up the .app packaging and launched JVM from a script with the app in
in a .jar should that work?

ATM I have no access to pre 10.13 .

The embedded JVM is:

JVM-Version     11.0.1+13
JVM-Vendor	Oracle Corporation
JVM-Name	OpenJDK 64-Bit Server VM          

For packaging I use 'jpackage' from jdk-13.

cheers Kusti

More information about the core-libs-dev mailing list