RFR: JDK-8219683: Investigate App Image layout on Mac
kevin.rushforth at oracle.com
Wed Apr 17 23:19:56 UTC 2019
I also would prefer just "runtime", but "Java.runtime" is at least
better than anything with "Plugin" in the name...
On 4/17/2019 3:45 PM, Andy Herrick wrote:
> On 4/17/2019 6:33 PM, Andy Herrick wrote:
>> On 4/17/2019 6:18 PM, semyon.sadetsky at oracle.com wrote:
>>> bug: https://bugs.openjdk.java.net/browse/JDK-8219683
>>> webrev: http://cr.openjdk.java.net/~ssadetsky/8219683/webrev.00/
>>> The fix moves Java runtime form Contents/PlugIns/Java.runtime to
>> Is there any reason "Java.runtime" shouldn't be just "runtime" like
>> other platforms ?
>> Please add comment to bug with pointer to webrev.
> Do we need to modify code in MacAppImageBuilder.signAppBundle() that
> treats "Contents/PlugIns" differently than other directories ?
More information about the core-libs-dev