jpackage EA 6 Build 49 (2019/4/19)

Kustaa Nyholm kustaa.nyholm at
Tue Apr 23 12:20:32 UTC 2019

Thanks Kevin

> On 23 Apr 2019, at 15.08, Kevin Rushforth <kevin.rushforth at> wrote:
> I didn't try your exact scenario yet (building the installer on 10.14 and running it on an earlier version, right?), but I have successfully run jpackage on macOS 10.12. Now that we have the new EA out, it would be worth trying it again.

I will try again. But that is not the actual scenario which was that the resulting .app file did not run on older macOS versions:

On 4/3/19, 11:25 PM, Kustaa Nyholm wrote:
> "You can't use this version of the application with this version of OS X.
> You have OS X 10.11.6. The application requires 10.13 or later."

I suspect this is just a matter of compiler settings for the C-stub code that starts the JVM in
which case it should be trivial to support almost any macOS version as I expect that the
code should not have many OS version dependent stuff in it.

> I note that by the time JDK 13 comes out, macOS 10.13 will be the oldest version of macOS that Apple will support. Having said that, I don't know of any reason why it should work as far back as 10.11 -- it just won't be supported.

As long as it works ;) 

You'd  be surprised how many people (are forced to) hang to older macOS versions because
they have expensive software that would require re-paying to get a version that runs
on modern macOS versions. I sometimes think that people (at Apple and Linux community)
do not realise that if the OS is free (as in beer) upgrading it often has a high price tag
in terms of work and sometimes cold cash.

So it really would be great if Java and by extension my software did not have to join the 
ranks of applications that force people to upgrade for no reason and no benefit.

wbr Kusti

More information about the core-libs-dev mailing list