RFR: JDK-8230521: rename --output/-o option and add default value (".")

Andy Herrick andy.herrick at oracle.com
Fri Sep 13 12:10:44 UTC 2019

On 9/12/2019 9:34 PM, Alexander Matveev wrote:
> Please review the jpackage fix for bug [1] at [2].
> This is a fix for the JDK-8200758-branch branch of the open sandbox 
> repository (jpackage).
> - Renamed "--output" to "--dest" and made it optional with default to 
> ".".
> [1] https://bugs.openjdk.java.net/browse/JDK-8230521
> [2] http://cr.openjdk.java.net/~almatvee/8230629/webrev.00/

I think this is wrong pointer to webrev, should be: 

Overall looks good - I think we need a little reworking of examples in 
help text.

When implementing other CLI changes, I didn't try to re-align the text 
of the examples because I knew this was coming.

If dest is optional, we should not use it in every example.  I was 
thinking of removing the option from all the examples except the first one.

This would also fix the excessively long line in the second example 
(caused by me adding "--package-type app-image".  check that it fits in 
80 columns after dest is removed.

(note - there is also an excessively long line in 
"MSG_Help_default_install_dir". can you re-layout this one to fit in 80 
columns ?)


> Thanks,
> Alexander

More information about the core-libs-dev mailing list