RFR: 8260337: Optimize ImageReader lookup, used by Class.getResource [v2]

Claes Redestad redestad at openjdk.java.net
Mon Jan 25 16:09:02 UTC 2021

On Mon, 25 Jan 2021 15:47:37 GMT, Alan Bateman <alanb at openjdk.org> wrote:

>> Claes Redestad has updated the pull request incrementally with one additional commit since the last revision:
>>   Copyrights and rename containsLocation
> src/java.base/share/classes/jdk/internal/module/SystemModuleFinders.java line 439:
>> 437:          * if not found.
>> 438:          */
>> 439:         private boolean containsLocation(String name) throws IOException {
> Can you rename this to containsImageLocation to keep it consistent with findImageLocation? Alternative rename findImageLocation. Also would be better for the description to be "Returns true if the given resource exists, false if not found".
> The changes to the jimage code will take time to review, probably should have 2 reviewers.


I've looped in @JimLaskey


PR: https://git.openjdk.java.net/jdk/pull/2212

More information about the core-libs-dev mailing list