RFR: 8273513: Make java.io.FilterInputStream specification more precise about overrides [v2]

Naoto Sato naoto at openjdk.java.net
Fri Sep 10 00:43:02 UTC 2021

On Thu, 9 Sep 2021 23:54:25 GMT, Brian Burkhalter <bpb at openjdk.org> wrote:

>> Modify the class level specification of `java.io.FilterInputStream` to be more exact about `java.io.InputStream` methods that it overrides.
> Brian Burkhalter has updated the pull request incrementally with one additional commit since the last revision:
>   8273513: Change key to select as suggested in CSR comment


src/java.base/share/classes/java/io/FilterInputStream.java line 90:

> 88:      * This method simply performs the call
> 89:      * {@code read(b, 0, b.length)} and returns
> 90:      * the  result. It is important that it does

Preexisting: an extra space before "result."


Marked as reviewed by naoto (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/5426

More information about the core-libs-dev mailing list