RFR: JDK-8266431: Dual-Pivot Quicksort improvements (Radix sort)
github.com+16439049+richardstartin at openjdk.java.net
Mon Sep 13 17:28:46 UTC 2021
On Thu, 13 May 2021 11:31:49 GMT, iaroslavski <github.com+43264149+iaroslavski at openjdk.org> wrote:
>> Perhaps we can resolve this issue in private - my email address is on my profile (or in the commits in `radix-sort-benchmark`)?
> @richardstartin And one more addon: my first version of Radix sort, see my github https://github.com/iaroslavski/sorting/tree/master/radixsort uses another name, like skipBytes, then renamed to passLevel.
> So, the common part is "skip". And this method has different number of parameters. I don't see any collision with your code.
@iaroslavski I would prefer to discuss this in private than here, but my argument is that the name `skipByte` came from Laurent's code, and that Laurent's code was clearly derived from my own within a fork of my repository. I linked the commits where you changed `skipByte` to `passLevel` and Laurent changed my name `canSkipLevel` to `skipByte`.
For me, this raises questions about the independence of your work from Laurent's, and Laurent's work is clearly derived from my own (and I don't think anyone is disputing the latter). I would be happy to sort this out in private.
More information about the core-libs-dev