RFR: 8274394: Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink

Andrey Turbanov github.com+741251+turbanoff at openjdk.java.net
Mon Sep 27 19:41:50 UTC 2021

I propose to replace usages of !Optional.isPresent() with Optional.isEmpty method.
It's makes code a bit easier to read.
Noticing negation before long chain of method calls is hard.


Commit messages:
 - [PATCH] Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink

Changes: https://git.openjdk.java.net/jdk/pull/5707/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5707&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8274394
  Stats: 8 lines in 5 files changed: 0 ins; 0 del; 8 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5707.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5707/head:pull/5707

PR: https://git.openjdk.java.net/jdk/pull/5707

More information about the core-libs-dev mailing list