RFR: 8274394: Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink
mchung at openjdk.java.net
Tue Sep 28 17:01:32 UTC 2021
On Sun, 26 Sep 2021 13:58:35 GMT, Andrey Turbanov <github.com+741251+turbanoff at openjdk.org> wrote:
> I propose to replace usages of !Optional.isPresent() with Optional.isEmpty method.
> It's makes code a bit easier to read.
> Noticing negation before long chain of method calls is hard.
Marked as reviewed by mchung (Reviewer).
More information about the core-libs-dev