review request (URGENT): 7051206: JSR 292 method name SwitchPoint.isValid is misleading to unwary users; should be hasBeenInvalidated
john.r.rose at oracle.com
Fri Jun 3 10:29:29 PDT 2011
On Jun 3, 2011, at 10:22 AM, Y. Srinivas Ramakrishna wrote:
> Looks good. Thanks for caring for the unwary user (which i unwittingly
> represented when i previously pointed out the admittedly somewhat
> subjective naturalness of the stable negative sense compared with
> the unstable positive sense).
Yes! You get some of the credit for setting up the sense of urgency about the name.
Charlie: By using the nonstandard name, we hope to make it harder to access the name casually. This applies to beans too.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the hotspot-compiler-dev