review request (URGENT): 7051206: JSR 292 method name SwitchPoint.isValid is misleading to unwary users; should be hasBeenInvalidated

John Coomes John.Coomes at
Fri Jun 3 14:47:43 PDT 2011

John Rose (john.r.rose at wrote:
> This is a changed method name (and inverted sense), replacing SwitchPoint.isValid.  Here's the updated javadoc:
> hasBeenInvalidated
> public boolean hasBeenInvalidated()
> Determines if this switch point has been invalidated yet.
> Discussion: Because of the one-way nature of invalidation, once a
> switch point begins to return true for hasBeenInvalidated, it will
> always do so in the future. On the other hand, a valid switch point
> visible to other threads may invalidated at any moment, due to a
                             ^^^ insert "be"
> request by another thread.
> ...

Aside from the trivial typo above, looks good to me.


More information about the hotspot-compiler-dev mailing list