review request (M): 7034977: JSR 292 MethodHandle.invokeGeneric should be renamed MethodHandle.invoke

Tom Rodriguez tom.rodriguez at
Wed May 11 10:53:54 PDT 2011

What about notifyGenericMethodType?  Should that be notifyGeneralMethodType?  There are others like ToGeneric and test/java/lang/invoke/  Is the intent just to clean up the public API language and worry about any internals later?

Looks good.


On May 11, 2011, at 9:02 AM, John Rose wrote:

> This is the engineering review for the name changes to remove the term "generic" from JSR 292.
> -- John

More information about the hotspot-compiler-dev mailing list