review request (M): 7034977: JSR 292 MethodHandle.invokeGeneric should be renamed MethodHandle.invoke
john.r.rose at oracle.com
Wed May 11 11:02:03 PDT 2011
Yes. Public API now.
Some of those names are (sadly) known to the vm.
-- John (on my iPhone)
On May 11, 2011, at 10:53 AM, Tom Rodriguez <tom.rodriguez at oracle.com> wrote:
> What about notifyGenericMethodType? Should that be notifyGeneralMethodType? There are others like ToGeneric and test/java/lang/invoke/InvokeGenericTest.java. Is the intent just to clean up the public API language and worry about any internals later?
> Looks good.
> On May 11, 2011, at 9:02 AM, John Rose wrote:
>> This is the engineering review for the name changes to remove the term "generic" from JSR 292.
>> -- John
More information about the hotspot-compiler-dev