review request (M): 7034977: JSR 292 MethodHandle.invokeGeneric should be renamed MethodHandle.invoke

John Rose john.r.rose at
Thu May 12 18:48:32 PDT 2011

On May 11, 2011, at 11:41 AM, Christian Thalinger wrote:

> On May 11, 2011, at 6:02 PM, John Rose wrote:
>> This is the engineering review for the name changes to remove the term "generic" from JSR 292.
> Looks good.  -- Christian

Thanks.  The final update is here:

After some suggestions from Joe Darcy, I adjusted some documentation.

Also, since EG wasn't unanimous about "general", I held off on changing the MethodType API.

-- John

More information about the hotspot-compiler-dev mailing list