Request for Review (XS): 7087445, Improve platform independence of JSR292 shared code
john.r.rose at oracle.com
Wed Sep 7 01:02:52 PDT 2011
On Sep 7, 2011, at 12:39 AM, Bertrand Delsart wrote:
> Do you prefer me to make this changes which will also impact the sharedRuntime_... files ? Any preference on the naming (info|pd_data) ?
I agree that more consistency would be better. When we do ports, sometimes we realize that the shared code contains invalid assumptions, and it is reasonable to clean those assumptions up as we discover them.
Therefore, here are my preferences in decreasing order:
1. Rename "fp" to "info" more uniformly, in both new and pre-existing code.
2. Rename new uses of "info" to "fp", accepting that the existing conventions imply that "fp" is not always a frame pointer.
3. (Least preferable:) Keep your changes as they are.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the hotspot-compiler-dev