Request for reviews (M): 7085860: JSR 292: implement CallSite.setTargetNormal and setTargetVolatile as native methods

Charles Oliver Nutter headius at
Thu Sep 8 13:13:03 PDT 2011

On Wed, Sep 7, 2011 at 2:09 PM, John Rose <john.r.rose at> wrote:
> Yes, looks good.  (I agree with Tom that "volatile_put" is harder to read
> than "put_volatile".  In the latter formulation, "volatile" modifies "put"
> more clearly.)

"volatile put" says to me "it may or may not's volatile
like that!" :)

- Charlie

More information about the hotspot-compiler-dev mailing list