review for 7086585: make Java field injection more flexible

Tom Rodriguez tom.rodriguez at
Fri Sep 9 09:45:14 PDT 2011

I had a side conversion with Coleen about this and she suggested moving RawFieldDescriptor into it's own file, which I think is a good idea.  She also commented on the confusion between RawFieldDescriptor and fieldDescriptor because of the name similarity.  I had looked at making fieldDescriptor a subclass of RawField at one point and I think I might be able to make that work.  I also think the RawFieldDescriptor name is bad.  How about FieldLayout?  Any opinions?  I had also considered fixing the capitalization of fieldDescriptor.


On Sep 8, 2011, at 3:47 PM, John Rose wrote:

> I've reviewed it.  It's excellent.  Extra thanks for getting rid of instanceKlass::next_offset.  -- John
> On Sep 8, 2011, at 1:38 PM, Tom Rodriguez wrote:
>> 1577 lines changed: 621 ins; 612 del; 344 mod; 65541 unchg
>> 7086585: make Java field injection more flexible
>> Reviewed-by:

More information about the hotspot-compiler-dev mailing list