RFR (S): 7174532: jdk/test/java/lang/Math/WorstCaseTests.java failing on x86
christian.thalinger at oracle.com
Thu Jun 7 11:22:20 PDT 2012
On Jun 7, 2012, at 9:43 AM, Vladimir Kozlov wrote:
> Thank you, Roland
> Could you rename verify_ctw() to verify_fpu_ctw()
Could we please name it verify_fpu_control_word? ctw is kind of overloaded.
> since there are other control words. Could you explain why it is only problem in VM 32-bit and add comment?
> Roland Westrelin wrote:
>> pow and exp as computed by the new intrinsics on x86 do not provide sufficiently precise results. This change increases the precision for the steps of the pow and exp computation.
More information about the hotspot-compiler-dev