RFR (M): 7023898: Intrinsify AtomicLongFieldUpdater.getAndIncrement()
vladimir.kozlov at oracle.com
Tue Jun 26 07:27:58 PDT 2012
I first thought about LoadStoreAdd, LoadStoreSet, LoadStoreCmpXchg. I don't like abbreviation (LS).
On 6/26/12 12:55 AM, Roland Westrelin wrote:
>> Even so John said you can use LS I would suggest to use full name. Why not use nodes names? For a example: GetAndAdd, GetAndSet, CompareAndSwap. It is easier to understand the meaning.
> Are you suggesting I drop the LS prefix as well?
> I would expect it to be good for readability that the name contains a hint that all those constants are related to each other.
They are used in the same method so one can see that they are related. I don't like abbreviation (LS) but I am not
strongly against it. It is up to you.
More information about the hotspot-compiler-dev