[9] RFR(S): CodeHeap::next_free should be renamed

Zoltán Majó zoltan.majo at oracle.com
Fri Jan 9 10:10:15 UTC 2015


please review the following small patch.

Bug: https://bugs.openjdk.java.net/browse/JDK-8065894

Problem: The method 'CodeHeap::next_free' does not return the next free 
HeapBlock as the name and the comment suggest. Actually, it returns the 
following block that is _not_ free, i.e., the next used block.

Solution: The name of the method and the comment about the method is 
changed accordingly.

Webrev: http://cr.openjdk.java.net/~zmajo/8065894/webrev.00/

Testing: JPRT.

Thank you and best regards,


More information about the hotspot-compiler-dev mailing list