RFR(S): CodeHeap::next_free should be renamed
tobias.hartmann at oracle.com
Fri Jan 9 10:17:24 UTC 2015
that looks good (not a reviewer). I like the comment!
On 09.01.2015 11:10, Zoltán Majó wrote:
> please review the following small patch.
> Bug: https://bugs.openjdk.java.net/browse/JDK-8065894
> Problem: The method 'CodeHeap::next_free' does not return the next free
> HeapBlock as the name and the comment suggest. Actually, it returns the
> following block that is _not_ free, i.e., the next used block.
> Solution: The name of the method and the comment about the method is changed
> Webrev: http://cr.openjdk.java.net/~zmajo/8065894/webrev.00/
> Testing: JPRT.
> Thank you and best regards,
More information about the hotspot-compiler-dev