RFR(S): 8066312: Add new Node* Node::find_user(int opc) method
zoltan.majo at oracle.com
Thu Jan 15 10:58:27 UTC 2015
thank you for the review!
On 01/14/2015 01:12 AM, John Rose wrote:
> One suggestion: Call it "find_out", not "find_user". The term "out" is more in use for Node than "user"; cf. Node::unique_out, raw_out.
I changed the names of the methods, as you suggested. Here is the
Thank you and best regards,
> — John
> On Jan 13, 2015, at 3:41 AM, Zoltán Majó <zoltan.majo at oracle.com> wrote:
>> please review the following small patch.
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8066312
>> Problem: There are some locations in the source code that search for users of a node of a particular type.
>> Solution: To simplify the code, this patch adds a new method, Node::find_user(int opc) that can be used for searching. This patch also updates some comments in the source code.
>> Webrev: http://cr.openjdk.java.net/~zmajo/8066312/webrev.00/
>> Testing: JPRT
>> Thank you and best regards,
More information about the hotspot-compiler-dev