RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

Doug Simon doug.simon at oracle.com
Fri Nov 3 21:11:24 UTC 2017

I added a justification to the bug which is copied below:

This method should be renamed to setNotInlinableOrCompilable for better consistency with existing OpenJDK source. Grepping through the sources available from  http://hg.openjdk.java.net/jdk10/hs: 

dsimon at kruger-4 ~/j/open> ag -i inlineable | grep -v setNotInlineableOrCompileable | wc -l 
dsimon at kruger-4 ~/j/open> ag -i inlinable | grep -v setNotInlineableOrCompileable | wc -l 
dsimon at kruger-4 ~/j/open> ag -i compileable | grep -v setNotInlineableOrCompileable | wc -l 
dsimon at kruger-4 ~/j/open> ag -i compilable | grep -v setNotInlineableOrCompileable | wc -l 

Based purely on these frequencies, we could rename to setNotInlineableOrCompilable but that looks internally inconsistent (why drop e from one word and not the other?).


> On 3 Nov 2017, at 20:03, Vladimir Kozlov <vladimir.kozlov at oracle.com> wrote:
> Looks good.
> But why you need to rename it? There is no explanation in JBS. Please, add it.
> Thanks,
> Vladimir
> On 11/3/17 8:55 AM, Doug Simon wrote:
>> Please review this small change to fix the spelling of a method's name.
>> https://bugs.openjdk.java.net/browse/JDK-8186478
>> http://cr.openjdk.java.net/~dnsimon/8186478
>> -Doug

More information about the hotspot-compiler-dev mailing list