RFR(XS): 8187884: [TESTBUG] compiler/classUnloading/anonymousClass/TestAnonymousClassUnloading failed with ClassNotFoundException

Calvin Cheung calvin.cheung at oracle.com
Mon Sep 25 18:27:28 UTC 2017

On 9/25/17, 10:32 AM, Vladimir Kozlov wrote:
> Looks good.
Thanks for your review.
> Why it worked before?
It isn't clear why it worked before.
 From the JPRT log file, one difference is the working dir.
Before the repo cosolidation:
Working dir: C:\jprt\T\P1\163225.<user>\s\test

Working dir: C:\jprt\T\P1\161245.<user>\s\closed\test

Note the "closed" dir before the "test" dir. But this may not be the 
cause of the failure since the classpath seems correct and the class exists.

Given that not everyone is encountering this problem, I'll hold on 
pushing this fix until after more investigations.

> Thanks,
> Vladimir
> On 9/22/17 4:24 PM, Calvin Cheung wrote:
>> This test failure started showing up after repo consolidation when 
>> running via JPRT -testset hotspot.
>> The problem went away if I change the file header similar to 
>> classUnloading/methodUnloading/TestMethodUnloading.java.
>> bug: https://bugs.openjdk.java.net/browse/JDK-8187884
>> webrev: http://cr.openjdk.java.net/~ccheung/8187884/webrev.00/
>> It passed JPRT -testset hotspot.
>> thanks,
>> Calvin

More information about the hotspot-compiler-dev mailing list