RFR: JDK-8212603: Need to step over GC barriers in Node::eqv_uncast()

John Rose john.r.rose at oracle.com
Wed Oct 17 18:03:01 UTC 2018

"uncast" is already a known term in C2 code, so repainting that bikeshed
would disconnect the new method from the old one.

> On Oct 17, 2018, at 10:59 AM, Aleksey Shipilev <shade at redhat.com> wrote:
> Does it deserve a better name? I don't know. There are "only" 25 usages of the method, and it can be
> renamed without much fuzz? For example, Node::eqv_canonical? Node::eqv_final? Node::eqv_stripped?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/hotspot-compiler-dev/attachments/20181017/e6fe65ae/attachment.html>

More information about the hotspot-compiler-dev mailing list